How to Solo Mine

Started by wowario, Jun 12, 2021, 01:39 PM

Previous topic - Next topic


Hi @wowario, after reading this post and comments I've come to the realization that wownerod and XMrig are quite different pieces of software.
Wownerod needs to download the Blockchain,  however xmrig does not. Being a noob to solo mining , is this a correct assumption?

If that's correct, I have several miners,  some running Ubuntu and others Windows. Will I need to have a copy of the entire WOW Blockchain local on each mining machine?

If that's the case, can you please provide guideance on what additional software I need to install and run in Ubuntu and Windows alongside XMrig and how I configure XMrig to reference the Blockchain when mining.

Sorry if I have got things completely wrong here.  I want to continue mining wow but just now sure what exactly in need to do to each miner to do so.

Thanks for your help.


Newbe question here.. Testing the wownerod command for windows .. and it is stating that the
"--spendkey"  is not a valid option?  no issue with the "--start-mining" option.??  Am I missing something?


you need to have the latest version (v0.10). Windows binaries will be out soon.


You have two options.

1. Run wownerod on each computer with the same command. You would have to sync up for each miner, but the blockchain is small, only about 3 GBs last I checked. This is the simplest option.

2. Or..... sync up 1 wownerod and point all miners to that node using XMRig proxy, which is a different piece of software. I am not a miner, so I am too familiar how to configure it, but I guess it would be something like:
`xmrig -o IP_ADDRESS:34568 --coin wownero -u YOUR_ADDRESS --spend-secret-key SPENDKEY --daemon`


(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


I followed the instructions but Im getting a message saying that the path is not recognized as an internal or external command. Any advice would be much appreciated.


I followed these instructions as well but I get the error "unsupported non-option argument' and then it lists my spend key. If someone could provide detailed instructions I'd greatly appreciate it.


Make sure you're using the lastest version of xmrig. Mine recognizes the added argument and is versionn 6.13+


I'm using the latest 6.13.0 xmrig proxy, made sure I'm copy and pasting these exact instructions so I don't know what I'm doing wrong.


Is there perhaps somewhere I can put the spend key in the config file instead?


Are you using xmrig proxy or just xmrig on one computer? I had no issue in using xmrig to connect to wownerod on the same computer but using the same instructions with xmrig proxy to a node on another computer is not working.



I'm working on getting the proxy working. (It's not picking up my hashes...)

> Is there perhaps somewhere I can put the spend key in the config file instead?

In the proxy, they added a `spend-secret-key` parameter to the pool section. Its not in their documentation... I had to read the source code to figure that out 😅


For now I'll mine with one machine and when we get the xmrig proxy working I'll get my other 2 going as well (currently mining monero). When I tried to mine with a full node on all 3 computers I run into router issues (they're all gpu mining as well).


Hi! I start mining at fork....I am find some blocks
but my balance is zero!!
Address and secret key provided at daemon, proxy and miners!!!

Where monets???


are u using an up-to-date wallet to check your balance?