How to Solo Mine

Started by wowario, Jun 12, 2021, 01:39 PM

Previous topic - Next topic


Ah, sorry. I *thought* you meant for me to be instructive for the benefit of everyone else here.

Look at `shares` in the xmrig-proxy output. 0 means no blocks yet. More than that means you've found a block. For an example of what finding a block looks like, there's an example on the other thread here:

As you can see there, `shares` increases to 1 and there's a little `+1` on that one line when the block is found.

**EDITED**: Sorry about the incomplete post--should be fixed now.


Hello, total noob here. I tried following the guide to get set up solo mining and was not smart enough to finish the last step, actually starting. Got the node all synced.

For reference I'm barely smart enough to pool mine XMR with xmrig (not actually profitable just doing this to learn and contribute)

So then I saw some instructions to mine wownero with xmrig and that its faster, so I tried setting that up and I think its working, but since I havent recieved a block reward yet, (nothing in my wowlet) and I dont know if the fact that I'm mining through xmrig means that my wownerod cant tell I'm mining? because it says "not mining" on status check, whereas xmrig is definitely getting "new jobs from localhost..."

Feel free to call me stupid, but would love some help. Might cross post to reddit too.


The "not mining" status on `wownerod` only tells you that `wownerod` itself isn't doing any mining. It looks like your `xmrig` is working properly, though, so you're in the clear.


Hey, I have a question because I noticed something weird.
I was mining for about 10 days straight with no luck and today after requiring an emergency reboot I noticed my start script didn't have the spend key specified. Does this make a difference? the only difference I've noticed so far after specifying the spend key is that my hashrate went up by a little bit (Only about 50 H/s) but otherwise I get the same outputs and everything.
I'm using debian 11 and the installation of wownerod was done with the cli .deb package btw.


thought the spend key was needed to sign the block, weird strange that it works with out.  maybe it hashes as expected until you win and then fails because no key is available to sign?


I am trying to set up the mining on MAC OS
I get the notification   unknown command: ./wownerod --start-mining HereIHavePutMyKey --spendkey HereIHavePutMyspendKey

what am I missing here?

Help would be appreciated. Thank zou.


"./wownerod" is the path to the wownero daemon, so you must be on the same folder :)


Hi ... what do you mean exactly with this "same folder" ?


I got it to work ... Thank you Kryfi !!!!


I have one more question .... I tried to increase the threads ... the command --mining-threads does not seem to be a known command .. in fact I get an "unknown command" response
Do you have any idea about the threads?


Yes it's working, you need to enter the argument like this:
./wownerod --start-mining HereIHavePutMyKey --spendkey HereIHavePutMyspendKey --mining-threads 8


Yes .. .I got that to work, too

So if you dont mind I have two more questions.

1. How many threads can I run?

2. I noticed that I get these type of notifications
|2022-03-21 20:55:30.401|I [  OUT] Sync data returned a new top block candidate: 406553 -> 406554 [Your node is 1 blocks (5.0 minutes) behind] |
|2022-03-21 20:55:30.401|I SYNCHRONIZATION started|
|2022-03-21 20:55:31.197|I Synced 406554/406554|
|2022-03-21 20:55:31.197|I SYNCHRONIZED OK|
|2022-03-21 21:18:28.011|W wownerod is now disconnected from the network|
|2022-03-21 21:18:28.011|W wownerod is now disconnected from the network|
|2022-03-21 21:18:31.524|I [ OUT] Sync data returned a new top block candidate: 406555 -> 406559 [Your node is 4 blocks (20.0 minutes) behind] |
|2022-03-21 21:18:31.524|I SYNCHRONIZATION started|
|2022-03-21 21:18:31.756|I Synced 406559/406559|
|2022-03-21 21:18:31.756|I SYNCHRONIZED OK|

How many of these are normal and what could I do to improve the connection?
How bad is this for the actual mining?

Thank you a lot.


1: For best results, set it to number of your physical cores.
2: You lose connection and your node is out of sync with the network.


Thank you ... I really appreciate your help

I am running three Computers right now ... two MACs and a PC with Ubuntu. All of them get these disconnection messages. I have 1.2kH/s and 1.0kH/s and 0.7kH/s right now. The 0.7kH/s is running with one core only, as I use that computer for music production and do not want to eat from it too much calculation power. They all get these disconnections at different times, I did check that. So it is not my internet connection.

I am also not sure what happens when I close the Laptops. How do I know it continues mining?

I know a lot of silly questions.


If you have several computers, I advise you to watch this tutorial instead :) After if you still have problems you can try to ask for help on Discord.