How To Mine Wownero With Xmrig Proxy

This guide is a work in progress…

On the computer running Wownerod:

I recommend using another computer on the same network as your miners. Having your wallet address and spend key in the config file on a VPS is insecure

  1. Create a server ( or use another computer ) to run Wownerod.
  2. Download Xmrig-Proxy to that server/computer
  3. Add "spend-secret-key": "your-key-here", to the pools section of the config.json file
  4. Update the rest of the pools section:
"pools": [
       {
           "coin": "wownero",
           "url": "127.0.0.1:34568",
           "user": "your wallet addres",
           "spend-secret-key": "your-key-here",
           "daemon": true
       }
],
  1. Install tmux and run tmux (gnu screen works too)
  2. Start Wownero: ./wownerod
  3. Open a new screen (ctrl-b c in tmux)
  4. Start Xmrig-Proxy: ./xmrig-proxy

On Your Miner(s):

  1. Updated the config file to point to your xmrig-proxy
"pools": [
        {
            "url": "xmrig-proxy-ip:port-number",
            "rig-id": "rig-name"
        }
    ],
  1. Run Xmrig : xmrig --spend-secret-key <your key here>

When configured correctly, your miners will receive jobs from Xmrig-Proxy and will show up in the output of xmrig.

How to See Your Miner’s Hashrate in Xmrig-Proxy

Happy Mining,
J. R.

4 Likes

Edit: I got it working thanks a lot!!! Like you’ve experienced it’s just not showing the hash rate on the xmrig proxy it just shows that the miner is connected!

2 Likes

Thanks @jrswab for putting this guide together.

I’ve followed the guide but have run in to the following error with my XMrig miner displaying:
"192168.0.47:34567 read error: ‘end of file’ " (see below)
wow-xmrig-read-error-Screenshot

Perhaps it’s has to do with my setup.

Server A:
Internal IP 192.168.0.47, Ubuntu LTS 20.04 running Wownerod.
I’ve installed XMrig Proxy with URL set to 127.0.0.1:34568 (as per the guide)
I have opened Port 34567 to this server (note the difference 34567 NOT 34568) to allow for external inbound traffic to Server A.

The Wownerod “Status” command displays the following:
$ status
Height: 332863/332863 (100.0%) on mainnet, not mining, net hash 40.59 MH/s, v19, 9(out)+33(in) connections, uptime 2d 5h 47m 56s

XMrig Proxy shows the following:
* ABOUT xmrig-proxy/6.13.0 gcc/9.3.0
* LIBS libuv/1.41.0 OpenSSL/1.1.1k
* MODE nicehash
* POOL #1 127.0.0.1:34568 coin wownero
* BIND #1 0.0.0.0:3333
* BIND #2 [::]:3333
* COMMANDS hashrate, connections, verbose, workers
[2021-07-07 21:13:33.678] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 0 (max 0) +0/-0

Laptop B:
Internal IP 192.168.0.84, Windows PC running XMrig 6.13.1 client
The configured URL to be 192.168.0.47:34568 via the Command line parameter:
xmrig.exe -o 192.168.0.47:34567 (plus added command line switches for secret spend key etc)

I have also tried swapping out the internal IP for external IP address, but I get the same error message: “Read Error: End of File”

I’m a newbie to solo mining and to Ubuntu, can someone please assist with how I can resolve this ‘read error’ issue?

P.S. Sorry for the long comment/post as I wanted to share details of my network setup as there may be others with a similar setup encountering the same issue. Thanks in advance.

In the xmrig proxy you should see bind # 1 showing port 3333 if it’s still at default. So in that case for laptop B to connect to Server A I believe you’d need to put in 192.168.0.47:3333

It seems that you have the IP address entered incorrectly in the config.json file.

When that file is invalid json you’ll see that end of file error.

@wow4reedom, @wownerian is correct here as well.

1 Like

Hey @wownerian and @jrswab,
Many thanks for your help, all I did was swap out the following:
OLD: xmrig.exe -o 192.168.0.47:34567 (plus the switches for secret spend key etc…)
NEW: xmrig.exe -o 192.168.0.47:3333 (plus the switches for secret spend key etc…)

Viola… Success!!!
I didn’t touch the config.json file. I would never have guessed to change the port number to 3333.

I’m super happy that I’m able to solo mine on my Windows laptop to help secure and support this project with such an amazing helpful community. :smile:

Please confirm one last thing… If I’m having my laptop B point to Server A using port 3333, is it still necessary to allow port forwarding to Server A via port 34567, or can I close that port?

2 Likes

You can close it. The only port that needs opened with the linked config example is 3333.

Port 34567 is used for P2P connections I believe and thus you don’t need to open that unless you want to have a public facing node.

1 Like

Update your proxies… 6.14 is out:

2 Likes

I have a question.
Is it nessesary to run xmrig with --spend-secret?I tried running xmrig without --spend-secret and it ran normally

If you have it set in the pools section of the config.json file then you do not need to add it as a command line argument.

I haven’t set in the ’config.json‘,but it still works.i curious that could I mine WOW without setting ‘–spend-secret’

What version of xmrig are you running?

make sure you are running latest version
you will need secret spend key to sign block header data otherwise the block will be rejected by the network

I must admit it is concerning that we can’t see our hash rate listed in xmrig proxy. If anyone finds a block please let us know. I have no blocks so far but with 40kh/s and only approx 5 days of mining I can’t say that this is abnormal.

1 Like

I could see all my found blocks in the xmrig proxy.
But no haashrate :(.

[2021-07-11 20:59:59.764] proxy 0.00 kH/s, shares: 7/0 +0, upstreams: 1, miners: 32 (max 37) +0/-0
[2021-07-11 21:00:57.378] proxy 0000 accepted (8/0+0) diff 12731488207 ip 10.11.100.35 (30 ms)
[2021-07-11 21:00:57.381] net 0000 new job from 127.0.0.1:34568 diff 12707827455 algo rx/wow height 333889
[2021-07-11 21:00:59.807] proxy 69025.89 kH/s, shares: 8/0 +1, upstreams: 1, miners: 32 (max 37) +0/-0
[2021-07-11 21:01:59.860] proxy 0.00 kH/s, shares: 8/0 +0, upstreams: 1, miners: 32 (max 37) +0/-0
[2021-07-11 21:02:34.900] net 0000 new job from 127.0.0.1:34568 diff 12697506988 algo rx/wow height 333890

1 Like

I have the same issue, but without shares too and no hashrate in the xmrig proxy output.

[2021-07-11 14:06:20.000] net 0000 new job from 127.0.0.1:34568 diff 12325026820 algo rx/wow height 333908
[2021-07-11 14:06:46.826] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +1/-0
[2021-07-11 14:07:46.888] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:08:46.950] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:09:47.011] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:10:20.183] * upstreams active: 1 sleep: 0 error: 0 total: 1
[2021-07-11 14:10:20.183] * miners active: 1 max: 1
[2021-07-11 14:10:47.069] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:11:47.130] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:12:47.195] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:13:47.257] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:14:47.324] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0
[2021-07-11 14:15:47.387] proxy 0.00 kH/s, shares: 0/0 +0, upstreams: 1, miners: 1 (max 1) +0/-0

I too see only shares when they are accepted, total workers connected, and total workers that have ever connected…

No hash rate on the workers, or there total hashrate.

[2021-07-11 13:46:09.248]  proxy    speed (1m) 0.00, (10m) 0.00, (1h) 0.00, (12h) 26.56, (24h) 13.28 kH/s
WORKER NAME             | LAST IP         | COUNT | ACCEPTED | REJ |  10 MINUTES |    24 HOURS |
1700                    | 192.168.1.11    |     0 |        1 |   0 |   0.00 kH/s |  13.28 kH/s |
[2021-07-11 13:46:12.718]  proxy    0.00 kH/s, shares: 1/0 +0, upstreams: 1, miners: 2 (max 2) +0/-0

Once I got the accepted share the funds did appear in my wallet shortly after.

guys, if you don’t know how to use XMRig properly, just mine directly from the wownero node

wownerod.exe --start-mining YOUR-ADDRESS --spendkey SECRET-SPENDKEY

1 Like