Wownero errors?

Hi I have the same issue on wownero for the link below

Would you please take a look at errors on your code?

Having looked at the thread, I can’t see what your error is.
The thread (from 2018) describes a potential glitch with Ledger when storing NEO, that being that the wallet ID changes when connected with the Ledger device.

As far as I know Wownero isn’t supported by Ledger [yet!].

Sorry, let me elaborate my thread. I see a glitch with Wownero Blockchain as it sometimes happens on Ledger and Metamask. The issue isn’t really about a device, but the glitch on blockchain. It’s common.

Here is a similar issue on Metamask. Would you please take a look at a potential glitch on blockchain?
Cheers.

The OP in that subthread confused their Ethereum address with their private key. Perhaps instead of linking to other threads with similar symptoms but wildly different causes, you could explain your situation in more detail?

What steps have you taken, what were you expecting to happen, and what happened instead? Are you having difficulty restoring from seed?

Please also specify what software (and which version) you are using.

1 Like

Thank you for your kind concern. Not really, all the issue comes down to the realm of a technical glitch of the blockchain.

My situation is also no different from the cases mentioned. The blockchain explorer shows a clear transaction record, however, it does not appear on any of the latest version of wallets.

Since these are wildly known issues, someone might investigate the glitch on the blockchain so the issues can truly be resolved.

  • Which wallet are you using?
  • Is your wallet up to date?
  • Which daemon is your wallet connecting to, and is that also up to date?

Hello, wowstash, wowlet, cli all of them are up to date with 0 restore height including daemon.
That is why I suggest to open the possibility for the technical glitch on the blockchain. Thank you.

It’s very common issue amongst wallets and worth taking a look at a glitch of the blockchain.

Okay, so are you saying that opening your seed in those wallets all show zero balance, even though there used to be?

You also mentioned that this happens in spite of the transaction being “on the blockchain”. Can you clarify that this means the transactions are visible on a blockchain explorer? Which one?

All the links you provided are related to Ethereum. Ethereum’s blockchain is transparent, so you can see all transactions on all addresses. However, Wownero has privacy features that make it next to impossible to find out which transaction is yours without having the private key, which is what you can derive from a seed.

Can you share what OS you are using? How many words long is your seed? Do you have the private key instead of the seed? What program generated the seed in the first place? Have you tried the CLI wallet?

Yes, that’s correct and the public address has clearly changed. I can clearly see the amount of transaction with the view key and have no problem to find all of my transaction with the exact amount.

With the same private key, I can find the record on the explorer. With the same seed number, there’s a different address with zero balance but still the same private key. I have no intention to doubt the features, but it’s just an issue happening to other wallets and non-crypto account as well.

https://www.charlotteobserver.com/news/nation-world/national/article244746762.html

I use 25 words on normal Windows OS, that did not have a glitch before, I have the same private key with a different wallet address, therefore, there is no balance. The program was the app probably a year ago, and I promise, I’ve tried all CLI and fully up to date wowlet and wowstash. Thank you.

Thank you. That is useful information. So if I understand you correctly, you still have your private view key, but your same seed generates a different public address. Does show_transactions in the CLI wallet still show your transfers? Can you try restoring from private spend key?

Yes, the public address has totally changed. And my same seed number led me to a the (different) address. It does not show any transfer record because it led me to access to a different address.

No, I tried but can not access to the original address. The view key works on explorer, but it does not work on wallets. This glitch is interesting, because when I access to a different wallet address and load seed number, it shows a different seed number as well. However, I could also access to the different address with the original seed number! How these can link to each other? Thanks for your insights.

Wownero, like Monero, has a feature that allows you to have multiple accounts. In Wownero, your standard address begins with Wo, while subaddresses (and all addresses of accounts other than the primary) begins with WW.

Try restoring just your view key in CLI, using --generate-from-view-key. show_transfers in CLI should show you all transactions from all accounts, but balance only shows the balance in your current account. show_transfers also tells you which account and address received the transfer, so you can switch to that account to spend the funds.

You’re right, I have multiple accounts. The thing is I sent directly to the subaddress, so there is no transfer record on the primary address. Wallets say the secret viewkey is invalid(it’s not). On blockchain, there is no problem with the same address and key. Thank you, but --generate-from-view-key on cli says unknown command, only tyrping viewkey works to see the key. Is there any other function I am able to access by typing in the subaddress and key? “address all” shows the only standard address in this case.

Sorry, I meant that you should start the CLI wallet using wownero-wallet-cli --generate-from-view-key NEW_WALLET_NAME plus any other options you usually have (like daemon address and stuff, but not wallet name since this generate option creates a new wallet).

Edited to correct: the argument is the name of the new wallet; wallet-cli will prompt you for the view key later.


When you first restore a wallet from seed (or key or what have you), address all will only show the primary address, since the wallet doesn’t know about your other accounts yet. show_transfers will show every transfer regardless of account, though. balance, on the other hand, will not.

Once you know which account number received the tx, you’ll have to manually create that account and switch to it. Repeatedly issue account new until account shows the correct number*. Then switch to the new account with account switch NUMBER.

If you only know the receiving address, you can also brute-force the account number by using address one-off ACCOUNT_NUMBER SUBADDRESS_NUMBER. Start each number at 0, then go through all reasonable combinations (I hope you remember approximately how many accounts or subaddresses you have made).

* I haven’t found a “smarter” way to do this, but I regularly restore from seed and this does work.

Your answer contains everything. I finally and successfully found the address and exact balance. Now, I understand where the issue came from and how to make things work properly By having the seed number, it’s totally possible to find them, but it just needs to put things in the right order and connection amongst the keys and addresses on Cli. I do appreciate it, this answer is the best and smartest answer I have ever read.

1 Like

Thanks. I’m glad this finally solves your problem.

Now that you have your account numbers in CLI, you can create the corresponding accounts in any other wallet you’d like to use.

1 Like