Wowlet v3.0.0 Released - update peps! 😎

Linux

Manual install

  • rename wowlet-v3.0.0-x86_64-linux binary to wowlet
  • move wowlet over to bin folder (/usr/bin, /usr/local/bin, or ~/.local/bin)
  • save org.wowlet.wowlet.desktop to /usr/share/applications
  • save wowlet.png to /usr/share/pixmaps
  • open wowlet from menu
  • to uninstall: delete .../bin/wowlet, /usr/share/applications/wowlet.desktop, ~/.config/wowlet and /usr/share/pixmaps/wowlet.png

Windows

  • download wowlet-v3.0.0-x86_64-windows.exe
  • double click on wowlet-v3.0.0-x86_64-windows.exe
  • to uninstall: delete wowlet-v3.0.0-x86_64-windows.exe and C:\Users\username\.config\wowlet

MacOS

  • unzip wowlet-v3.0.0-x86_64-macos.zip
  • move wowlet.app to Applications folder
  • to uninstall: delete wowlet.app
1 Like

Hey folks, I have a problem with my Wowlet. I had version 2.0 which tried to sync for a week or more. Now I read that I should install version 3.0 Did that but it’s not working. The wowlet shows up in my dock (iOS) and then disappears again – although I allowed my mac to open it. Can someone help?

Can’t get it to work. Guess gonna blaze n chill till someone makes an AppImage or a .deb or something.
I open the windows exe with Wine. Ha! It works.

Linux

I have managed to move the wowlet folder to /usr/bin

How can I save the file from [org.wowlet.wowlet.desktop]? If I click on that link I see a code made of 15 lines. How do I download it?
Thanks

PS: I have created a file with the text editor and pasted the codes inside. I have then managed to move everything to the folders but the wownero app is not in the menu, How can I launch it?

Do I have to change anything where it says [Desktop Entry]?

When you open the link with the org.wowlet.wowlet.desktop it has e “raw” button in the right upper corner, right click n save link as. I got the icon to appear in my menues, but the wowlet file doesn’t work for me. As I mentioned in my post I open the windows exe with Wine and PlayOnLinux.

1 Like

Have you set the execute permission on the binary?

chmod +x /usr/local/bin/wowlet

Add sudo and adjust path as needed.

I tried that. I also tried to change the owner to root. Didn’t work. I looked into compiling from source and it’s not a walk in the park either.

Interesting. What OS and architecture are you on? Can you post the output of ldd /path/to/wowlet ?

xubuntu
$ ldd /usr/local/bin/wowlet
linux-vdso.so.1 (0x00007fff70284000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fd061c00000)
libX11-xcb.so.1 => /usr/lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007fd061bfb000)
libxcb-icccm.so.4 => /usr/lib/x86_64-linux-gnu/libxcb-icccm.so.4 (0x00007fd061bf4000)
libxcb-image.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-image.so.0 (0x00007fd0619ef000)
libxcb-shm.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007fd0619ea000)
libxcb-keysyms.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-keysyms.so.1 (0x00007fd0619e5000)
libxcb-randr.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-randr.so.0 (0x00007fd0619d0000)
libxcb-render-util.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render-util.so.0 (0x00007fd0619c9000)
libxcb-render.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007fd0619ba000)
libxcb-shape.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-shape.so.0 (0x00007fd0619b5000)
libxcb-sync.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007fd0619ab000)
libxcb-xfixes.so.0 => /usr/lib/x86_64-linux-gnu/libxcb-xfixes.so.0 (0x00007fd0619a1000)
libxcb-xkb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-xkb.so.1 (0x00007fd061981000)
libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fd061957000)
libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007fd06181a000)
libxkbcommon-x11.so.0 => /usr/lib/x86_64-linux-gnu/libxkbcommon-x11.so.0 (0x00007fd06180f000)
libxkbcommon.so.0 => /usr/lib/x86_64-linux-gnu/libxkbcommon.so.0 (0x00007fd0617cd000)
libglib-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fd0616a4000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fd061553000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fd061530000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fd06133e000)
/lib64/ld-linux-x86-64.so.2 (0x00007fd06744b000)
libxcb-util.so.1 => /usr/lib/x86_64-linux-gnu/libxcb-util.so.1 (0x00007fd061138000)
libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007fd061132000)
libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fd061128000)
libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fd0610b5000)
libbsd.so.0 => /usr/lib/x86_64-linux-gnu/libbsd.so.0 (0x00007fd06109b000)

What exactly happens when you try to run wowlet from the terminal? Do you get any output or abnormal exit codes?

/usr/local/bin/wowlet; echo $?

./wowlet
Illegal instruction (core dumped)
$ /usr/local/bin/wowlet; echo $?
Illegal instruction (core dumped)
132

1 Like

Okay, I’m stumped. I would’ve guessed that there’s a CPU incompatibility, but as you said the Windows version works fine in Wine. It might be something more subtle.

What CPU do you have (see /proc/cpuinfo)? Is there any chance you can run wowlet under gdb and get a stack trace? (Try gdb /path/to/wowlet, type run, then after it crashes, backtrace. See also: Monero – Obtaining stack traces and core dumps, To run Monero within gdb.)

Reading symbols from /usr/local/bin/wowlet…
(No debugging symbols found in /usr/local/bin/wowlet)
(gdb) run
Starting program: /usr/local/bin/wowlet
[Thread debugging using libthread_db enabled]
Using host libthread_db library “/lib/x86_64-linux-gnu/libthread_db.so.1”.

Program received signal SIGILL, Illegal instruction.
0x00005555557e935b in ?? ()
(gdb) backtrace
#0 0x00005555557e935b in ?? ()
#1 0x00005555557e947e in ?? ()
#2 0x0000555556cf26fd in ?? ()
#3 0x00007ffff7706040 in __libc_start_main (main=0x5555557c2040, argc=1,
argv=0x7fffffffdff8, init=0x555556cf26b0, fini=,
rtld_fini=, stack_end=0x7fffffffdfe8)
at …/csu/libc-start.c:264
#4 0x00005555557ee529 in ?? ()
(gdb)

1 Like

Okay, it looks like your CPU takes exception to an AVX vmovaps instruction. (You can confirm it yourself with a disas 0x00005555557e935b,+16.) That’s funny because the Windows binary, which you can run, also includes AVX instructions. I’ll need to dig further into the code.

To rule out your CPU as a factor, can you confirm whether or not it supports AVX? (Look for avx and xsave in /proc/cpuinfo.)

fpu vme de pse tsc msr pae mce cx8 apic sep mtr
r pge mca cmov pat pse36 clflush dts acpi mmx f
xsr sse sse2 ht tm pbe syscall nx lm constant_t
sc arch_perfmon pebs bts rep_good nopl cpuid ap
erfmperf pni dtes64 monitor ds_cpl vmx smx est
tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm p
ti tpr_shadow vnmi flexpriority dtherm
Seems like no avx shows up

1 Like

That confirms the issue, then. Wowlet’s Linux binary does not run on non-AVX machines. I’d open an issue on Gitea, but since registration is still broken…

I still haven’t worked out why the Windows binary works for you, but not the Linux one. It might be down to different compiler options or version. There’s probably a compiler flag to make it work, but as you said, compiling from source looks a bit involved.

Thanks for taking the time to investigate. Sorry I couldn’t have been of more help!

At least you tried. Maybe we will get fix eventually. :slight_smile: Cheers!

1 Like

Hey @wowario, thanks for posting the latest feature summary and releases to the Wowlet wallet.

I’m really enjoying using the wallet. It’s so easy to use and I love how the latest forum posts and memes are available right within the wallet. This makes this wallet fun and a pleasure to use. Please pass on the feedback to the other devs.

Speaking of Wowlet devs, I have an idea that I’d was hoping you might be able to run by the team (only if you think it’s worthy). Please note: I’m not a coder and hence I’m not even sure is the blockchain can even support this idea.

Here is my idea…
One of the founding principles of Wownero is privacy. Wouldn’t it be nice if built-in to the base layer was an option to send an encrypted text message (or meta-data) with each transaction?

Let me provide an real world example…
Let’s say I want to send a community member a donation in $WOW. Wouldn’t it be nice if I could attach to the donation a short encrypted message that could only be read by the recipient in their Wowlet wallet. The message could have a character limit - like Twitter had when it launched with a 140 chr limit, thus deterring people from attaching the dictionary to a transaction (haha).

This message would be encrypted on the blockchain and visible in the recipients Wowlet wallet once the transaction is in the process of being confirmed.

How this could be funded
This feature would be “opt-in” via a check box. Once the Wowlet user checks this box, a text box would appear allowing the user to enter text. As the user types in there message there would be a character countdown and also a small fee would be charged per character (the longer the message the higher the fee).

This fee would cover the cost of transmitting more data with a transaction and the fee would be split 2 ways:
a) 50% goes to the miner
b) 50% would be deposited in to the Wowlet Developer Fund (to re-coup the cost to developing this feature)

Thoughts anyone?

hey mate

I think this feature might already exist in wowlet 3.
if you’re in wowlet, navigate to ‘Tools’ then > ‘Sign/Verify message’. There you can write a message and sign it by hashing it with your wallet ID. Then the reciever of the message can verify using the same tool.
or to send a message with a transaction you could use the ‘description’ field. not sure what the character limit is but it’s enough for a short message and shouldn’t burden the network thus shouldn’t be too costly.
Though there is the possibility of evolving the signnature verification feature to allow wallet to wallet communication I can imagine a few ways this could compromise security. Eg/ sending phishing messages, using links to de-obfuscate users, running scams etc.
I think that for the time being, the most interesting comunication integration looks to be IRC - think devs are noobifying an IRC client to tie in with WOW.

h00t

1 Like

Hi @wowowl , Thanks for the reply.
I did a test and sent some WOW from one Wowlet wallet to another and I added a some text as a Description (less than 20 characters). The Description text appears in the “Sender’s” transaction history, but there is no description text appearing in the “Recipient’s” transaction history.

Could you please do a test to confirm that this works for you in Wowlet 3.0.0? Thanks.