Wowlet 3.0 minimal requirement?

Hello,

i would like to upgrade Wowlet to 3.0. (Releases - wowlet - WowGit!) previously i used prepared bin for Linux (Ubuntu Focal 20.04 LTS). But now i got this error
Illegal instruction (core dumped)
not sure where it dump trace or something only error i was able to find is from kernel.log
traps: wowlet[2311] trap invalid opcode ip:55d3dc49735b sp:7ffef491a400 error:0 in wowlet[55d3dc202000+5158000]

first error should suggest old CPU and missing instruction? Currently using AMD Phenom™ II X4 955 Processor (flags: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc cpuid extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt nodeid_msr hw_pstate vmmcall npt lbrv svm_lock nrip_save) so no AVX and so.

Also docker build failed on this machine, don’t remember exact error, but I can try to re-run it again tomorrow if needed.

So is there any minimal requirement for running Wowlet in these terms?

Thanks for your answer.