Solo mining on mac help

i need help mining on mac.

i already launched wownerod successfully, added my wallet address to “miner.conf” (do I need to add spendkey?)

Typed: ./wownerod --start-mining MY-ADDRESS --spendkey SECRET-SPENDKEY

But nothing’s happening?

if you want to use “miner.conf” file, you need to type:

./wownerod --config-file=miner.conf

alternatively, you can type the full command in the terminal as:

./wownerod --start-mining MY-ADDRESS --spendkey SECRET-SPENDKEY

to check your mining status, type status

I tried ./wownerod --config-file=miner.conf

but nothing.

Am i doing this correctly?

connect by entering: /Users/admin/Downloads/wownero_macOS_v0.10.0.0_beefa5e62e/wownerod

then enter: ./wownerod --config-file=miner.conf

check if wownerod is being blocked by macos Open a Mac app from an unidentified developer - Apple Support

enter your wallet address and secret spend key in miner.conf file

run ./wownerod --config-file=miner.conf

1 Like

nice! but now im getting

‘Specify wallet file name (e.g., MyWallet). If the wallet doesn’t exist, it will be created.’

where to find my wallet name?

you name it whatever you want

to get wallet address, type address

to get secret spend key, type spendkey

1 Like

thanks!

im now getting

‘background mining is enabled, but not started, waiting until start triggers’

then entered: ./wownerod --config-file=miner.conf

which says

unknown command: ./wownerod --config-file=miner.conf ?

how to start?

you should disable background in wallet. type set setup-background-mining 0
exit the wallet
you need to run the wownerod command from terminal

1 Like

finally got it working thank you wowario!