Old version of wallet that runs on Mac OS 10.14.6?

Is there an older version of the WOWlite desktop wallet that will still run on Mac OS 10.14.6? If so, where can i download it? Or is that not advisable? (The latest version requires an operating-system upgrade & i’m not ready for that at this time.) Are there alternative wallets? I’ve tried Wowstash but it doesn’t work.

1 Like

I was able to compile this and get it running on 10.14 if you still need it, the tickers/reddit pieces don’t seem to work but the wallet part does. I might be able to upload the binary for you somewhere if you still need it.

The build instructions are the URL below that I followed.

Getting QT 5.15.1 part of the build is slightly different as there is no offline installer for that version, and if you don’t use 5.15.1 the build will fail. I can add that part in a little while, I would have to get my notes from the other week. Let me know if you are interested.

Build instructions:
wowlet/wowlet: WOWlet is a free Wownero desktop wallet - docs/BUILDING.md at master - wowlet - WowGit!

If you have homebrew installed on your Mac OS you can run these:

brew install tor
brew services start tor

And the reddit ticker etc. will work (wowlet needs Tor to operate)

1 Like

thank you dsc! I will give that a try.
Do you happen to have access to modify the build docs on git? I modified the mac os steps for Qt slightly and maybe it could help some users.

I fixed git.wownero.com yesterday so that new user registrations work again. Feel free to submit a PR :slight_smile:

1 Like

awesome, that tor suggestion worked. I will file a pr in a bit.

thanks again!

1 Like

Was trying to get setup but I can’t seem to get signed in or create a new user or use my account from here.

I am hitting a 500 error or get stuck at register new account / link to existing account options. Tried different browsers ff/chrome/brave(chrome) but seems to be the same across all of those.

Oh, sorry, I fixed that just now. Everything broke after upgrading. Please try again.

1 Like

Thank you. Login worked initially but when I committed and tried to git push origin it fails on login

did you use ssh for checkout? you may need to add your key to gitea

1 Like

I did not use ssh to checkout just git-clone over https, let me look around a bit more to get my bearings. I appreciate your reply.

I’ve added a key and using ssh now. I am getting closer but I think I don’t have the correct permissions to push. I am not sure I doing it right but feels like it should work.

git clone gitea@git.wownero.com:wowlet/wowlet.git
cd wowlet/docs
git checkout -b update-docs
git add BUILDING.md
git commit -m “docs: adding Qt build hints for mac os”
#: ~/Downloads/builds/wowlet/docs$ git push -u origin update-docs
Gitea: Unauthorized
Gitea: Unauthorized
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

-auth seems ok
#: ssh -T gitea@git.wownero.com
Hi there, $username! You’ve successfully authenticated with the key named ******, but Gitea does not provide shell access.
If this is unexpected, please log in with password and setup Gitea under another user.

try this:

  • make a fork of wowlet using gitea fork button
  • checkout your fork
  • commit changes to your fork
  • make a pull request to wowlet/wowlet using the gitea interface
1 Like

Ok thank you! I understand the process now,

I am actually getting a 500 error when hitting the fork button logged in as my user so I may have jumped past that initial step by accident.

can you fork other repos?

yes, i just was able to fork wownero/wownero so might be just wowlet repo specific.

I’m seeing the error too. I will fix it tomorow. Sorry for the inconvenience.

repository does not exist [id: 0, uid: 0, owner_name: , name: ]

;(

2 Likes

Thanks again, no problem at all. I will check back on it tomorrow. I do appreciate all the help.

Was able to fix it just now. Forking works again.

2 Likes