Issue connecting to my local Wownero Node [RESOLVED]

Hi Wownero Community,
I have a PC on my home local network running latest version of wownerod (Junky Jeff).

When I am logged on that PC, I can run the following command:
curl 127.0.0.1:34568/get_info
I see the node is running and the sync is up to date.
The local IP address of this PC = 192.168.0.120

When I go to a different PC on the same home network, I can ping the Wownero PC using ping 192.168.0.120 and that works fine.
However, when I type in to a web browser the following:
http://192.168.0.120:34568/get_info
or in terminal
curl http://192.168.0.120:34568/get_info

I get the Error message "Refused to Connect"

I have also tried on my mobile phone that is connected to the same Home Network via WiFi.

I enter into my Stack Wallet the IP Address of Wownero server = 192.168.0.120 and I enter Port Number = 34568

I get the following error: “Server Unreachable”.

Can please tell me what I’m doing wrong, or how to fix this issue so that I can connect to my Wownero node on my local network to sync my wallet?

Thanks in advance.

In case you didn’t do this, you need to start wownerod with --rpc-bind-ip 0.0.0.0 to allow other devices to connect to it.

1 Like

Many thanks @_xxfedexx , this worked however it did throw an error saying I needed to add the following:

--confirm-external-bind

Once I appended the above string it all worked so now I can sync my Stack Wallet using my very own Wownero node. Awesome Stuff!