How to Solo Mine

I’m using the latest 6.13.0 xmrig proxy, made sure I’m copy and pasting these exact instructions so I don’t know what I’m doing wrong.

Is there perhaps somewhere I can put the spend key in the config file instead?

Are you using xmrig proxy or just xmrig on one computer? I had no issue in using xmrig to connect to wownerod on the same computer but using the same instructions with xmrig proxy to a node on another computer is not working.

1 Like

@wownerian

I’m working on getting the proxy working. (It’s not picking up my hashes…)

Is there perhaps somewhere I can put the spend key in the config file instead?

In the proxy, they added a spend-secret-key parameter to the pool section. Its not in their documentation… I had to read the source code to figure that out :sweat_smile:

1 Like

For now I’ll mine with one machine and when we get the xmrig proxy working I’ll get my other 2 going as well (currently mining monero). When I tried to mine with a full node on all 3 computers I run into router issues (they’re all gpu mining as well).

1 Like

Hi! I start mining at fork…I am find some blocks
but my balance is zero!!
Address and secret key provided at daemon, proxy and miners!!!


Where monets???

are u using an up-to-date wallet to check your balance?

I am use wowstash and cli wallet
bbalance is zero!!!

check the block hash of mined blocks in Blockchain Explorer. If nothing comes up, the chain might have been reorged and your blocks orphaned. If your blocks are in the blockchain, then try restoring a new wallet with your seed from height 0. Make sure you are using latest wallet cli version and synced up with network.

blocks in blockchain!!!
but balance zero in wowstash!!!

try using latest wallet cli version and synced up with network.

no…zero zero
maybe problem has xmrigproxy?

maybe, check with XMRig support

I am sure this is in here somewhere but is there a windows build? I am trying to build but having issues with Cygwin and ZMQ headers.

alguem ja conseguiu mineirar ou receber algo… sera posivel executar mais de um no com a mesma carteira

I have also tried to use an xmrig proxy for all my 64 nodes. Unfortunately without success. On the Linux VM with xmrig proxy I got your wownerod miner running and left it active (only stop_mining activated on the miner) Blockchain is completely downloaded and synchronised on the machine.

On this VM I also managed to get an xmrig miner running. But unfortunately no xmrig proxy!!!

I have only entered wallet data via command line ./xmrig-proxy -o 127.0.0.1:34568 --coin wownero -u YOUR-ADDRESS --spendkey SECRET-SPENDKEY --daemon

xmrig proxy reports the following:

./xmrig-proxy: unrecognized option '--spend-secret-key'
./xmrig-proxy: unrecognized option '--daemon'
[2021-07-05 02:23:52.081] ./xmrig-proxy: unsupported non-option argument 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'
 * ABOUT xmrig-proxy/6.13.0 gcc/5.4.0
 * LIBS libuv/1.41.0 OpenSSL/1.1.1k
 * MODE nicehash
 * POOL #1 127.0.0.1:34568 coin wownero
 * BIND #1 0.0.0.0:3333
 * BIND #2 [::]:3333
 * COMMANDS hashrate, connections, verbose, workers
[2021-07-05 02:23:52.084] net 127.0.0.1:34568 read error: "end of file"
[2021-07-05 02:23:54.085] net 127.0.0.1:34568 read error: "end of file"

So I can’t find a way to start xmrig proxy in conjunction with wownerod.

But xmrig miner is running on this machine. My problem is that I cannot give internet access to my nodes and can only run a miner via proxy.

Please think about a procedure for this, otherwise there is no possibility to mine Wownero with my system of over 1.2 MHz/s.

Thanks!

check if connections are being blocked by a firewall. open ports 34567 and 34568

find out what is the local LAN IP for computer running the node and enable RPC by adding this to wownerod, --p2p-bind-ip=NODE_LAN_IP --p2p-bind-port=34567 --rpc-bind-ip=NODE_LAN_IP --rpc-bind-port=34568 --disable-rpc-ban=1 --restricted-rpc=1 --rpc-ssl=autodetect and ping the node from other PCs within the network to check it is reachable with this call:

curl http://NODE_LAN_IP:34568/json_rpc -d '{"jsonrpc":"2.0","id":"0","method":"get_info"}' -H 'Content-Type: application/json'

if you can ping the node, try running:

 ./xmrig-proxy -o NODE_LAN_IP:34568 --coin wownero -u YOUR_ADDRESS --spend-secret-key SPENDKEY --daemon

I’m sorry I’m not quite understanding. So I have 3 rigs, and I need to run wownerod on one of them, and then xmrig on that one that’s running the node and xmrig proxy on the other 2 I believe. I tried to run wownerod with --p2p-bind-ip=NODE_LAN_IP --p2p-bind-port=34567 --rpc-bind-ip=NODE_LAN_IP --rpc-bind-port=34568 --disable-rpc-ban=1 --restricted-rpc=1 --rpc-ssl=autodetect with filling in my local lan IP but it won’t start with these settings. My router cannot handle running a node on all 3 rigs unfortunately so I’m still only able to mine with one out of 3 (only 15kh/s). Running wownerod on one computer and linking xmrig to it is pretty simple to me but once I get into getting 3 computers on running off of one node with xmrig proxy I’m really at a loss. If we could have someone make step by step instructions I’d be more than happy to pay for it with WOW it’s just that I’ve been trying for many hours and I can’t seem to figure it out.

I am not very familiar with XMRig.

Perhaps you could open a bounty on WFS for someone to write a step by step guide on using XMRig proxy on multiple computers.