How to install Wonerujo Android wallet

  1. Download and install F-Droid.apk
  2. Go to Official Monerujo F-Droid repo and copy the repo’s “Direct HTTPS” address
  3. Open F-Droid, go to “Settings”, under My Apps click on “Repositories”, Click the “+” on top right corner, paste the Direct HTTPS address and click on “ADD”
  4. Toggle enable for the Official Monerujo F-Droid repo
  5. Click back “←”, click on “Latest”, touch on screen and move finger down to update all repos
  6. Click on green magnifying glass symbol “:mag:” in the bottom right and search “wownero”
  7. Click on “Wonerujo” and then click “INSTALL”
  8. After a couple minutes, you should see the “OPEN” button, click on it to open Wonerujo wallet
  9. Wonerujo icon will also be in your phone’s apps, you can drag and drop the icon to home screen to have an easy shortcut to the wallet.

If you find the mobile wallet useful, please consider donating to the Monerujo team. Even 1 WOW makes a difference. As a free & open source project, community support is important.

WOW: Wo4g66NnQsd2XvoLjn9RATRK6QS4w1UXmZrQJwRKn8HX9kqNpoAMbqKi9JmQMz5pMbRdW6Zahjcu57JXcYWk4zVk2w47gu6Dq (OpenAlias:
XMR: 4AdkPJoxn7JCvAby9szgnt93MSEwdnxdhaASxbTBm6x5dCwmsDep2UYN4FhStDn5i11nsJbpU7oj59ahg8gXb1Mg3viqCuk (OpenAlias:


The one from the Google Play Store didn’t work well, but this version works great!

1 Like

How did you get it to work. Mine does not want to connect to any node?

For some reason cyberwow is the only one that comes up any ideas?

Did you add the official repo to the F-Droid store? If so, try to sync/refresh and see if it shows up.

Hello, a few days ago I tried to download the wallet for android, but it told me it was not compatible, could you try to enable it to LG smartphones? , Thank you.

Maybe you have an older version of Android? Try updating if possible.

I am in the same boat. I have tried uninstalling, reinstalling, and using custom nodes as well as core. No dice. I saw in the that the mobile app doesn’t work…

Does this wallet still work? tried to install on my android with no luck, crashes every time I try to create a wallet. Phone is up to date and i have tried re-installing a dozen times.

Unfortunately with the latest hard fork the mobile wallet no longer works.