How to Solo Mine

Started by wowario, Jun 12, 2021, 01:39 PM

Previous topic - Next topic


I'm not sure if this is helpful, but here is what i used on xmrig (none proxy) 6.14

./xmrig 0 -o --coin wownero -u xxxxxxx --spend-secret-key xxxxxx --daemon -t 4

Below is my output. Currently mining from my macpro to my node in my vm farm. I know that 0 didn't do anything, but without it for some reason it fails to work. I have five more miners to put online. when i do, I'll report back how they're working.

[2021-08-12 08:59:39.916] ./xmrig: unsupported non-option argument '0'

***** **ABOUT** **XMRig/6.14.0** **clang/10.0.0**

***** **LIBS libuv/1.41.0 OpenSSL/1.1.1k hwloc/2.4.1**

***** **HUGE PAGES** **supported**

***** **1GB PAGES** **unavailable**

***** **CPU Intel(R) Xeon(R) CPU X5670 @ 2.93GHz (2)** **64-bit** **AES**

L2:**3.0 MB** L3:**24.0 MB** **12**C/**24**T NUMA:**1**

***** **MEMORY** **45.9/48.0** GB (96%)

DIMM 1: **4** GB **DDR3 @ 1066 MHz** 0x4D33393342353137304742302D5948392020

DIMM 2: **4** GB **DDR3 @ 1066 MHz** 0x202020202020202020202020202020202020

DIMM 3: **16** GB **DDR3 @ 1066 MHz** 0x484D543432475237424D5234432D47372020


DIMM 5: **4** GB **DDR3 @ 1066 MHz** 0x4D33393342353137304648302D4348392020

DIMM 6: **4** GB **DDR3 @ 1066 MHz** 0x4D33393342353137304648302D4348392020

DIMM 7: **16** GB **DDR3 @ 1066 MHz** 0x484D543432475237424D5234432D47372020


***** **MOTHERBOARD Apple Inc.** - **Mac-F221BEC8**

***** **DONATE 1%**

***** **ASSEMBLY auto:****intel**

***** **POOL #1** **** coin **wownero**

***** **COMMANDS** **h****ashrate,** **p****ause,** **r****esume, re****s****ults,** **c****onnection**

***** **OPENCL** **disabled**

***** **CUDA** **disabled**

[2021-08-12 08:59:39.929] **net** **use daemon** ****

[2021-08-12 08:59:39.929] **net** **new job** from **** diff **23490M** algo **rx/wow** height **343320** (2 tx)

[2021-08-12 08:59:39.929] **cpu** use **argon2** implementation **SSSE3**

[2021-08-12 08:59:39.929] **randomx** **init dataset** algo **rx/wow (****24** **threads)** seed c7b8adcca301bdbe...

[2021-08-12 08:59:43.362] **randomx** **allocated** **2336 MB** (2080+256) huge pages **0% 0/1168** **+JIT** (3433 ms)

[2021-08-12 08:59:47.009] **randomx** **dataset ready** (3647 ms)

[2021-08-12 08:59:47.010] **cpu** use profile ***** **(****4** **threads)** scratchpad **1024 KB**

[2021-08-12 08:59:53.349] **cpu** **READY** threads **4/4 (4)** huge pages **50% 2/4** memory **4096 KB** (6340 ms)

[2021-08-12 09:00:51.055] **miner** **speed** 10s/60s/15m **1306.8** n/a n/a **H/s** max **1336.8 H/s**


Noob here, running Wowlet on Mac Os and just synced the miner via terminal.

I'm not the most terminal savvy kind of person so I did my best to copy and paste the code with my addresses but I'm getting unknown command error for both --startmining and --spendkey.

Did I place my addresses in right piece of the command?

I'm grabbing the "primary address" and the "secret spend key" from WOWlet -> keys

I'm inputting it like this:

./wownerod --start-mining **my primary address entered here** --spendkey **my secret spend key entered here**

Am I doing something wrong?

See the pic, not sure if matters but I blacked out the keys, I figured one was a secret I should protect it.

Please offer some wisdom


You're typing into the `wownerod` console, which recognises a different set of commands. Exit `wownerod` first with Ctrl-C, then at the `$` prompt, type in your command again.

Also, it's not really visible in the pic, but double check that your command is all one long line.


Thanks for the tips,  

it's still not working, I've tried exiting Wownerod and entering the commands via terminal only and not getting anywhere. Command line is all one line, I copy and past the whole thing just as this tutorial above has it, I've only put in my key and addressed is the only difference.

Any ideas? I swear anytime I have to input commands into anything like this It hardly ever works. I feel like command line terminals are for the gifted.

Pleas help


you first need to `cd` (change directory) to location where you saved the files.
and then enter `./wownerod --start-mining YOUR-ADDRESS --spendkey SECRET-SPENDKEY`


Thanks for the tip! I'm getting closer but still not quite there.

I am supposed to be changing directory and entering ./wownerod --start-mining YOUR-ADDRESS --spendkey SECRET-SPENDKEY in the MAC OS terminal and not the Wownerod terminal correct?

I tried to change directory in wownerod and didn't get anywhere. The OS terminal however did give me some form of progress despite the errors. Please see image.

Thanks for the help!


you get this when you already have an instance of wownerod running


you got it running, type `status` to check if you are mining


I have tried following the instructions, downloaded the files, installed, in Linux.
At the CLI I entered ./wownerod --start-mining Woxxxxx --spendkey xxxxxxxxx

I get messages like:
Sync data returned a new top block candidate: 5301 -> 348999 [Your node is 343698 blocks (3.3 years) behind]

At the moment it is going no further than this, but earlier it got further with other messages such as some IP addresses followed by the word blocked, and messages about not being connected to the network.

So how do I get started?


download latest version

make sure you have written down your wallet's seed and have it saved somewhere safe.

delete .wownero folder

run `./wownerod`

once you are fully synced, exit and run `./wownerod` again with --start-mining Woxxxxx --spendkey xxxxxxxxx


I'm not making any progress.

I downloaded latest version v0.10.1.0, extracted all contents to desktop and deleted the folder

Synchronized wownerod,

Opened a new terminal window, changed directory to Desktop and entered  --start-mining Woxxxxx --spendkey xxxxxxxxx

Received the following errors:
|2021-09-02 03:54:01.851|F Error starting server: Failed to bind IPv4 (set to required)
|2021-09-02 03:54:01.851|I Deinitializing core...
|2021-09-02 03:54:01.856|I Stopping cryptonote protocol...
|2021-09-02 03:54:01.856|I Cryptonote protocol stopped successfully
|2021-09-02 03:54:01.856|E Exception in main! Failed to initialize p2p server.

I type status in wownerod terminal and get this:
Height: 349357/349357 (100.0%) on mainnet, **not mining**, net hash 119.23 MH/s, v19, 12(out)+0(in) connections, uptime 0d 0h 4m 49s

So I'm still not mining.

I guess the complication of this stuff is why I sold my ASIC miners in 2015, if I only could have figured that out then and not given up I'd have waaaaay more BTC.

I did notice a message in wownerod after syncing:
You are now synchronized with the network. You may now start wownero-wallet-cli.

tried running wownero-wallet-cli, moved my wallet file to desktop and entered the wallet name with no luck. Should I be attempting to run this wownero-wallet-cli or is the "--start-mining Woxxxxx --spendkey xxxxxxxxx" the optimal way to go?

Anyway please help, I would really like to understand how to cpu/gpu mine all sorts of coins. Getting this to work is a first step.

If I can succeed in getting this to run it'll give me some confidence.

Thank you

Peep the screenshot:


you are almost there.

you should only run **one instance** of wownerod, not two.

type `exit` and restart it like this `./wownerod --start-mining Woxxxxx --spendkey xxxxxxxxx`


My dude thank you! I think understand now.

Mining Started!


congratulations, you are a solo miner. remember rewards are random and there is no guarantee when you would win a block. It could take a few days or a month or two.