Wownero wallet CLI "Internal Error" - Please help

Started by wow4reedom, Dec 24, 2021, 04:34 PM

Previous topic - Next topic


Hello Wownero Community,

I'm brand new to the Wownero wallet CLI. I'm trying to stake my WOW on Avalanche using the excellent instructions by @wowario here -

After transferring my WOW from my Wowlet wallet (which took several transfers of smaller amounts) to my CLI wallet, I ran into a spot of trouble. I got the following internal error when I try to execute the "locked_sweep_all" command:

> Error: internal error: Known ring does not include the spent output: 2095277

I can confirm that :-
  • 1) My CLI wallet is fully synced
  • 2) The balance in my CLI wallet is fully unlocked.
  • 3) I have no outgoing transfers from this wallet (I only transferred funds into this wallet)
  • 4) I tried to execute the "locked_sweep_all" command in Wowario's instructions, but then I saw a "Warning Message" and so I decided to cancel that transaction as I was afraid I was doing something wrong.  
  • 5) I have since tried sending a small amount of WOW from CLI wallet to my Wowlet wallet and I got the same "internal error" message above.
  • 6) I'm not a very technical person and I'm brand new to the CLI wallet.

Can anyone provide some ideas on ways to resolve this internal error as I'd really like to participate and support the staking program?  

Thanks in advance.


This happens when you have some old small outputs from the pool mining days.

- delete  `~/.wow-shared-ringdb` hidden folder (in windows, `C:\ProgramData\wow-shared-ringdb`)
- run `wownerod` and wait until it is synced
- and then make a new wallet with the 25 word mnemonic seed of the problematic wallet
> wownero-wallet-cli --restore-deterministic-wallet
- restore from height 0
- you can test the new wallet by sending the entire amount back to yourself without locking it by running:
> sweep_all ADDRESS
- if it works, you can then use  the "locked_sweep_all" command


Thanks for Step-by-Step guide to help me resolve this issue.
I've been able to sweep all funds to a new wallet.
Thanks for your help @wowario and for being such a helpful member in this privacy-focused community.


I just ran into this error on my CLI wallet and this method did not seem to work for me. I'm able to move some of the wow, but have two accounts that give me the internal error.

1.deleted the shared folder and synced the node
2. made a new wallet using the restore command
3. restore height was 0
4. sweep_all ADDRESS
but still I get the error, I tried this several times and no luck, I also tried connecting to a remote node and still received the internal error.
Are there any other methods to try?
edit: this is on debain 11


is there some dust transactions in wallet?  try doing the same process and sending smaller amounts to a new wallet instead of sweep all


ya could be dust, I send and receive my meme tips with this is sub account.
But No that didn't seem to work either, I synced the chain and restored the wallet on a different computer and it worked.